Avatar of ElJefe

ElJefe

light bar doesn't turn off with high beams

I have installed a Led light bar on the front of a 99 Pajero IO, it turns on fine but when you turn it off it doesn't turn off straight away which isn't great for the on coming vehicle. I was told it could be the relay and was told to replace the relay with a 40amp relay but when I got to Auto 1 they couldn't find a 40amp only a 30 amp. 

is the 30 amp still not cutting the mustard or do you think there could be more wrong to cause the delay? 

or do I require a different kind of relay because its only a single led light bar?? 

NAVMAN

do you have hid or led headlights?

I had an issue when i fitted hid to my headlights that the spotlights didnt work properly. I had to add a load generator to get them to switch properly

ElJefe OP

just standard headlight was thinking about upgrading to HID eventually just havent got there yet.

More from our Forum


martinbrown8987 in Members Introduction
Introduction From Claude

Hi, I'm Claude,  I'm from Brisbane Queensland Australia. I love caraving and camping. I have a...

Macgomes in Mitsubishi Challenger
I Want To Update My MMCS In My Mitsubishi Challenger 2010.

Hello everyone,, The MMCS in my car is running a 2008 version of the software, and is quite limited...

Macgomes in General 4WD
The Importance Of Looking Good Is Mostly Overlooked.

Hello everyone,, Most of us look down our nose at people who don't take their rubbish home. But how...

ronald in Mitsubishi Pajero
Reading Ecu

good day i  have a question iam sorry my english got a bit rusty.the engine of my car ...

Tommo4523 in General 4WD
First Car

Hi all,I am starting to think about getting my first car and i want it to be a 4wd as a find them...

jo3546984698476874 in Mitsubishi Pajero
Pajero Diy Diagnostics

Hi All, I hate working on cars, but no choice as an Age Pensioner with no savings. Please reply...

RobertWilson in Electrical Bromance
Windscreen Wiper Intermittent Control

the intermittent aspect on my Overland 2002 has stopped working, only operates as slow on all...

1mak in Track Test
Glasshouse Mountains 4WD Map?

Hey guys, haven't been able to locate Big red yet in the Glasshouse Mountains and wondering if...