A good 4WD Hire at Gold Coast?

Hey y'all,

my mates and I are planning a trip to fraser island. They don't have a 4x4 so we need to hire one for them. I guess they need something decent with a lot of space like a Landcruiser Trooper or a big Prado. Anyone knows a good place to hire a 4x4 near the Gold Coast that doesn't cost an arm and a leg?

Thanks
NAVMAN

I think your biggest hurdle will be them actually allowing you to take their vehicle to Fraser, all the rental companies that come to mind cave a clause to the effect that if you put it on a boat say goodbye to any insurance yiu thought you had. I'm also pretty sure that they won't let rental cars north of Indian Head.
I'm pretty sure there is a rental company that will allow their car to go on Fraser but I can't remember their name at the moment.

More from our Forum


Liska in Members Introduction
Plenty Hwy And QLD Section Of Savannah Way, Advice For Our Adventure Please?

Hi all! Liska here, I am new to the forum! I am planning a 4WD road trip with our Suzuki Grand...

1mak in Website Critique
Model Specific

how do we start a section in the model specific?? I'd like to add rodeo to the holden section...

1mak in Ssangyong Offroad Cars
Welcome To Our New Ssangyong Forum

Hey guys,our member Scoteye asked for a Ssangyong specific forum as a central point for...

Scoteye in Website Critique
Unable To Update Profile.

Just went to update "my work" Unable to do so. No big deal, just thought I would note it.

Scoteye in Offroad Tyres and Rims
New BFG KM3 On Wrangler JK

Hey guys. I have just updated to a new set of tyres. My second hand Nitto Trail Grapplers have seen...

Scoteye in Electrical Bromance
Windscreen Wiper Intermittent Control

the intermittent aspect on my Overland 2002 has stopped working, only operates as slow on all...

Scoteye in General 4WD
First Car

Hi all,I am starting to think about getting my first car and i want it to be a 4wd as a find them...

Scoteye in Mitsubishi Pajero
Noise In Front End Under Brakes

we have a weird as hell noise coming from front brakes not pads as they were replaced 6 months ago...